Kasutaja tarvikud

Lehe tööriistad


mikrotik:ipv6

IPV6 Harjutustöö nr 1

Eeldused:

  • Algteadmised IPv6 aadressi tüüpidest ja ülesehitusest

Eesmärgid

  • IPV6 sisse lülitamine (RouterOS, Windows, Linux)
  • IPV6 SLAAC (StateLess Address AutoConfiguration) kasutamine
  • IPV6 seadistamine RouterOS keskkonnas
  • Staatilise IPV6 marsruutimise seadistamine.

vajalikud seadmed

  • Mikrotik ruuterid 3 tk (füüsilised või virtuaalsed)
  • Linux operatsioonisüsteemiga arvuti (füüsiline või virtuaalne)
  • Windows operatsioonisüsteemiga arvuti (füüsiline või virtuaalne)

Seadmed

  • Mikrotik ruuterid:
    • ISP - ruuter, mis ühendab omavahel R1 ja R2 (eesmärgiga luua paketide teekonna kirjeldamise vajadus)
    • R1 - kontor nr 1
    • R2 - kontor nr 2
    • Lae alla 3 ruuterit - Virtualbox template
  • Arvutid
    • Klient1 - R1 kontori testmasin
    • Klient2 - R2 kontori testmasin

Seadmete vahelised ühendused

  • ISP ether1 < Virtualbox: Internal: isp1
  • R2 ether2 < Virtualbox: Internal: R2 > ISP ether3
  • R1 ether3 < Virtualbox: Internal: R1_LAN > Klient1
  • R2 ether3 < Virtualbox: Internal: R2_LAN > Klient2

vaata topoloogia joonist

Töös kasutatav IPv6 prefiks

Töös kasutame 2001:0DB8::/32 prefiksit, mis on spetsiaalselt eraldatud ülesannetes ja juhendmaterjalides kasutamiseks. 1)

IPv6 aadressi alamvõrkude jagamiseks soovitan kasutada https://ipv6st.codeplex.com/ leitavat IPv6 kalkulaatorit.

Seade Liides Aadress
ISP ether2 2001:db8:1:ffff::2/64
ISP ether3 2001:db8:2:ffff::2/64
R1 ether2 2001:db8:1:ffff::1/64
R1 ether3 2001:db8:1:2::1/64
R2 ether2 2001:db8:2:ffff::1/64
R2 ether3 2001:db8:2:2::1/64

Seadmete vaheline liiklus tuleb korraldada kasutades staatilist ruutimist vastavalt tabelile:

Ruuter Prefix Kuhu Kommentaar
ISP 2001:db8:1::/48 2001:db8:1:ffff::1/64 ISP oskab R1 võrku ruutida
ISP 2001:db8:2::/48 2001:db8:2:ffff::1/64 ISP oskab R2 võrku ruutida
R1 ::/0 2001:db8:1:ffff::2/64 R1 saadab kõik ISP ruuterile
R2 ::/0 2001:db8:2:ffff::2/64 R2 saadab kõik ISP ruuterile

Kuidas teha

Pane kõik alla laetud masinad tööle ja logi admin kasutajaga sisse.

#lisa IPv6 addressid liidestele ISP ruuteris
/ipv6 address add address=2001:db8:1:ffff::2/64 interface=ether2
/ipv6 address add address=2001:db8:2:ffff::2/64 interface=ether3
/ipv6 address print

Kirjuta IPd ka teistesse ruuteritesse vastavalt tabelile.

Kui see on tehtud tuleb teha ruutimine.

#teeb ruutimis kirjed ISP ruuteris
/ipv6 route add dst-address=2001:db8:1::/48 gateway=2001:db8:1:ffff::1
/ipv6 route add dst-address=2001:db8:2::/48 gateway=2001:db8:2:ffff::1
/ipv6 route print

Ruutimis kirjed tuleb teha ka teistes ruuterites.

Kuidas testida ruuterites

# ühenduse kontroll R1-ga
ISP> ping 2001:0db8:0001:ffff::1
 
# ühenduse kontroll R2-ga
ISP> ping 2001:0db8:0002:ffff::1
 
# kontrolli ühendust ruuteriga R2
R1> ping 2001:0db8:0002:0002::1
 
# kaardista teekond ruuterist R2 ruuterisse R1
R2> /tool traceroute 2001:0db8:0002:0002::1

Kuidas testida

Lisa topoloogiasse 1 Windows operatsioonisüsteemiga masin ja 1 Linux operatsioonisüsteemiga masin. Ühenda nad võrkudesse:

  • Virtualbox: Internal: R1E2 - Linux
  • Virtualbox: Internal: R2E2 - Windows

Veenud, et mõlemad operatsioonisüsteemid saavad IP aadressi (Linux ifconfig ja ipconfig Windows).

Proovi pingida Linuxist Windowsi ja vastupidi.

Proovi teekonda kaardistada traceroute abil: Linux, Windows

IPV6 staatilise aadressi seadistamine Windowsi kliendile Vt: http://technet.microsoft.com/en-us/library/cc732106.aspx

Linuxi IPV6 seadistus: Linux https://wiki.ubuntu.com/IPv6

#/etc/network/interfaces with an editor and add:
iface eth0 inet6 static
        address SINU_IP_V6_AADRESS
        netmask 64

Küsimused

  • ISP on eraldanud sulle IPv6 võrgu, mis on järgmine: 2001:0BAD:BEEF:3200::/62. Sinu ülesandeks on jagada see võrk neljaks alamvõrguks. Millised 4 /64 võrku sa saad?
    • Vastus:
      • Võrk 1:
      • Võrk 2:
      • Võrk 3:
      • Võrk 4:
  • Mitu bitti moodustab hosti osa IPv6 aadressist?
    • Vastus:
  • Kirjuta järgnev IPv6 aadress lühendatud kujul: 2001:0012:0000:0000:00AB:0000:0000:09FB
    • a. Vastus:

Töö esitamine

  • Näita, et said võrgu nõutud tasemel tööle (IPV6 liiklus läheb Linuxist Windowsi)
  • Probleemide korral küsi
  • Vasta küsimustele!

Iseseisev ülesanne

XX - tähistab sinu arvuti numbrit.

ISP on eraldanud R2 võrgule uue prefiksi ning vana prefix eemaldatakse 1 nädala jooksul. Sinu ülesandeks on viia R2 võrk üle uuele IPv6 prefixile 2001:0db8:20XX::/48

ISP ruuterile määra aadress: 2001:0db8:20XX:ffff::2/64

Edasi toimeta oma parema äranägemise järgi. Tee topoloogias vajalikud ruutingu korrektuurid.

R2 ether2 liidesel peab olema kättesaadav võrk prefikiga /64


  1. käsk ping6
  2. käsk: ping
  3. käsk: traceroute6
  4. käsk: traceroute
mikrotik/ipv6.txt · Viimati muutnud: 2018/12/05 16:49 persoon it